$re = '/(https?:\/\/)(.+?)([a-z-]*)\/?$/m';
$str = 'https://something.com/a/lomg/ur-l/
http://something.com/a/lomg/url
https://something.com/a/lomg/url/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);