// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?:\/\/)(.+?)([a-z-]*)\/?$").unwrap();
let string = "https://something.com/a/lomg/ur-l/
http://something.com/a/lomg/url
https://something.com/a/lomg/url/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}