re = /(https?:\/\/)(.+?)([a-z-]*)\/?$/m
str = 'https://something.com/a/lomg/ur-l/
http://something.com/a/lomg/url
https://something.com/a/lomg/url/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end