#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)(?= +=[^=])"
Local $sString = "if(ruleMode == "test") " & @CRLF & _
"" & @CRLF & _
"ruleMode = "test"; " & @CRLF & _
"" & @CRLF & _
"validator = (percent >= margin.lower) && (percent <= margin.upper); " & @CRLF & _
"" & @CRLF & _
"fooo123 = (percent >= margin.lower) && (percent <= margin.upper); "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")