$re = '/(\w+)(?= +=[^=])/m';
$str = 'if(ruleMode == "test")
ruleMode = "test";
validator = (percent >= margin.lower) && (percent <= margin.upper);
fooo123 = (percent >= margin.lower) && (percent <= margin.upper); ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);