using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)(?= +=[^=])";
string input = @"if(ruleMode == ""test"")
ruleMode = ""test"";
validator = (percent >= margin.lower) && (percent <= margin.upper);
fooo123 = (percent >= margin.lower) && (percent <= margin.upper); ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}