re = /(\w+)(?= +=[^=])/m
str = 'if(ruleMode == "test")
ruleMode = "test";
validator = (percent >= margin.lower) && (percent <= margin.upper);
fooo123 = (percent >= margin.lower) && (percent <= margin.upper); '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end