import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)(?= +=[^=])";
final String string = "if(ruleMode == \"test\") \n\n"
+ "ruleMode = \"test\"; \n\n"
+ "validator = (percent >= margin.lower) && (percent <= margin.upper); \n\n"
+ "fooo123 = (percent >= margin.lower) && (percent <= margin.upper); ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}