#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w,\s-]+\.[A-Za-z]{3}$"
Local $sString = "resource.zip" & @CRLF & _
"resource.jpg" & @CRLF & _
"resource.ext" & @CRLF & _
"resource" & @CRLF & _
"resource." & @CRLF & _
"resource.d" & @CRLF & _
"resource.long" & @CRLF & _
"resource.mov" & @CRLF & _
"resour#ce.png" & @CRLF & _
"" & @CRLF & _
"// You can show origina post on albertcolom.com/blog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")