// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w,\s-]+\.[A-Za-z]{3}$").unwrap();
let string = "resource.zip
resource.jpg
resource.ext
resource
resource.
resource.d
resource.long
resource.mov
resour#ce.png
// You can show origina post on albertcolom.com/blog";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}