using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w,\s-]+\.[A-Za-z]{3}$";
string input = @"resource.zip
resource.jpg
resource.ext
resource
resource.
resource.d
resource.long
resource.mov
resour#ce.png
// You can show origina post on albertcolom.com/blog";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}