const regex = /^[\w,\s-]+\.[A-Za-z]{3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w,\\s-]+\\.[A-Za-z]{3}$', 'gm')
const str = `resource.zip
resource.jpg
resource.ext
resource
resource.
resource.d
resource.long
resource.mov
resour#ce.png
// You can show origina post on albertcolom.com/blog`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}