import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w,\\s-]+\\.[A-Za-z]{3}$";
final String string = "resource.zip\n"
+ "resource.jpg\n"
+ "resource.ext\n"
+ "resource\n"
+ "resource.\n"
+ "resource.d\n"
+ "resource.long\n"
+ "resource.mov\n"
+ "resour#ce.png\n\n"
+ "// You can show origina post on albertcolom.com/blog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}