#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?imx)# Match the beginning of the string." & @CRLF & _
"^" & @CRLF & _
"# Match the HTTP(S) domain and path of re101." & @CRLF & _
"https?:\/{2}regex101\.com\/r\/" & @CRLF & _
"# Capture the unique ID." & @CRLF & _
"(?<id>[a-z\d]{1,6})" & @CRLF & _
"# Capture the revision." & @CRLF & _
"(?:\/(?<rev>\d+))?" & @CRLF & _
"# Do not care about anything else..."
Local $sString = "http://regex101.com/r/mH1fN5" & @CRLF & _
"https://regex101.com/r/fW0vZ2" & @CRLF & _
"https://regex101.com/r/wY0rM7/22#pcre" & @CRLF & _
"ftp://www.google.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")