const regex = /# Match the beginning of the string.
^
# Match the HTTP(S) domain and path of re101.
https?:\/{2}regex101\.com\/r\/
# Capture the unique ID.
(?<id>[a-z\d]{1,6})
# Capture the revision.
(?:\/(?<rev>\d+))?
# Do not care about anything else.../gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('# Match the beginning of the string.
^
# Match the HTTP(S) domain and path of re101.
https?:\\\/{2}regex101\\.com\\\/r\\\/
# Capture the unique ID.
(?<id>[a-z\\d]{1,6})
# Capture the revision.
(?:\\\/(?<rev>\\d+))?
# Do not care about anything else...', 'gim')
const str = `http://regex101.com/r/mH1fN5
https://regex101.com/r/fW0vZ2
https://regex101.com/r/wY0rM7/22#pcre
ftp://www.google.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}