import Foundation
let pattern = ##"""
# Match the beginning of the string.
^
# Match the HTTP(S) domain and path of re101.
https?:\/{2}regex101\.com\/r\/
# Capture the unique ID.
(?<id>[a-z\d]{1,6})
# Capture the revision.
(?:\/(?<rev>\d+))?
# Do not care about anything else...
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = ##"""
http://regex101.com/r/mH1fN5
https://regex101.com/r/fW0vZ2
https://regex101.com/r/wY0rM7/22#pcre
ftp://www.google.com/
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)