// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?imx)# Match the beginning of the string.
^
# Match the HTTP(S) domain and path of re101.
https?:\/{2}regex101\.com\/r\/
# Capture the unique ID.
(?<id>[a-z\d]{1,6})
# Capture the revision.
(?:\/(?<rev>\d+))?
# Do not care about anything else...").unwrap();
let string = "http://regex101.com/r/mH1fN5
https://regex101.com/r/fW0vZ2
https://regex101.com/r/wY0rM7/22#pcre
ftp://www.google.com/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}