re = /# Match the beginning of the string.
^
# Match the HTTP(S) domain and path of re101.
https?:\/{2}regex101\.com\/r\/
# Capture the unique ID.
(?<id>[a-z\d]{1,6})
# Capture the revision.
(?:\/(?<rev>\d+))?
# Do not care about anything else.../imx
str = 'http://regex101.com/r/mH1fN5
https://regex101.com/r/fW0vZ2
https://regex101.com/r/wY0rM7/22#pcre
ftp://www.google.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end