package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?<name>[^)]+)\)\((?<type>\d+)\)\((?<percent>[^)]+)\)(?:\((?<who>[^)]+)\))?`)
var str = `(name)(123)(percent)(who)
(name)(123)(percent)
(cgfddfv fl)(3)(yo 15 %)(vk.com/sda)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}