const regex = /\((?<name>[^)]+)\)\((?<type>\d+)\)\((?<percent>[^)]+)\)(?:\((?<who>[^)]+)\))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((?<name>[^)]+)\\)\\((?<type>\\d+)\\)\\((?<percent>[^)]+)\\)(?:\\((?<who>[^)]+)\\))?', 'g')
const str = `(name)(123)(percent)(who)
(name)(123)(percent)
(cgfddfv fl)(3)(yo 15 %)(vk.com/sda)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}