re = /\((?<name>[^)]+)\)\((?<type>\d+)\)\((?<percent>[^)]+)\)(?:\((?<who>[^)]+)\))?/
str = '(name)(123)(percent)(who)
(name)(123)(percent)
(cgfddfv fl)(3)(yo 15 %)(vk.com/sda)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end