import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((?<name>[^)]+)\\)\\((?<type>\\d+)\\)\\((?<percent>[^)]+)\\)(?:\\((?<who>[^)]+)\\))?";
final String string = "(name)(123)(percent)(who)\n\n"
+ "(name)(123)(percent)\n\n"
+ "(cgfddfv fl)(3)(yo 15 %)(vk.com/sda)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}