package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z0-9]{6})\.[a-zA-Z]{3}$`)
var str = `ezie5k.php
yre45t.php
8975d5.php
3sfb8k.php
123ghu
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}