$re = '/^([a-zA-Z0-9]{6})\.[a-zA-Z]{3}$/m';
$str = 'ezie5k.php
yre45t.php
8975d5.php
3sfb8k.php
123ghu
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);