import re
regex = re.compile(r"^([a-zA-Z0-9]{6})\.[a-zA-Z]{3}$", flags=re.MULTILINE)
test_str = ("ezie5k.php\n"
"yre45t.php\n"
"8975d5.php\n"
"3sfb8k.php\n"
"123ghu\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")