// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z0-9]{6})\.[a-zA-Z]{3}$").unwrap();
let string = "ezie5k.php
yre45t.php
8975d5.php
3sfb8k.php
123ghu
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}