const regex = /^([a-zA-Z0-9]{6})\.[a-zA-Z]{3}$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z0-9]{6})\\.[a-zA-Z]{3}$', 'mg')
const str = `ezie5k.php
yre45t.php
8975d5.php
3sfb8k.php
123ghu
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}