#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+?$"
Local $sString = "+123456489" & @CRLF & _
"+1(850) 555-1234" & @CRLF & _
"+1-850-555-1234" & @CRLF & _
"+88 66 8880 1234" & @CRLF & _
"dsadsadas" & @CRLF & _
"3213123213" & @CRLF & _
"+123456489+" & @CRLF & _
"++1(850) 555-1234" & @CRLF & _
"3424324324+" & @CRLF & _
"sdsad989890" & @CRLF & _
"324324s32432" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")