import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?$";
final String string = "+123456489\n"
+ "+1(850) 555-1234\n"
+ "+1-850-555-1234\n"
+ "+88 66 8880 1234\n"
+ "dsadsadas\n"
+ "3213123213\n"
+ "+123456489+\n"
+ "++1(850) 555-1234\n"
+ "3424324324+\n"
+ "sdsad989890\n"
+ "324324s32432\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}