package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?$`)
var str = `+123456489
+1(850) 555-1234
+1-850-555-1234
+88 66 8880 1234
dsadsadas
3213123213
+123456489+
++1(850) 555-1234
3424324324+
sdsad989890
324324s32432
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}