const regex = /^\+?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?$', 'mg')
const str = `+123456489
+1(850) 555-1234
+1-850-555-1234
+88 66 8880 1234
dsadsadas
3213123213
+123456489+
++1(850) 555-1234
3424324324+
sdsad989890
324324s32432
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}