# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^A-ZÄÖÜ]*((?:\s*[A-ZÄÖÜ][a-zäöüß'-]*)+)[^A-ZÄÖÜ]*/$1, /gm;t' <<< "Obama Mama told: Reporters in 19. Washington-Post in That he and Netanyahu-lll are opposed to Iran's calls for \"Death To America\"."