use strict;
my $str = 'Obama Mama told: Reporters in 19. Washington-Post in That he and Netanyahu-lll are opposed to Iran\'s calls for "Death To America".';
my $regex = qr/[^A-ZÄÖÜ]*((?:\s*[A-ZÄÖÜ][a-zäöüß'-]*)+)[^A-ZÄÖÜ]*/mp;
my $subst = '$1, ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";