#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^A-ZÄÖÜ]*((?:\s*[A-ZÄÖÜ][a-zäöüß'-]*)+)[^A-ZÄÖÜ]*"
Local $sString = "Obama Mama told: Reporters in 19. Washington-Post in That he and Netanyahu-lll are opposed to Iran's calls for "Death To America"."
Local $sSubst = "$1, "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)