re = /[^A-ZÄÖÜ]*((?:\s*[A-ZÄÖÜ][a-zäöüß'-]*)+)[^A-ZÄÖÜ]*/m
str = 'Obama Mama told: Reporters in 19. Washington-Post in That he and Netanyahu-lll are opposed to Iran\'s calls for "Death To America".'
subst = '$1, '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result