using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^A-ZÄÖÜ]*((?:\s*[A-ZÄÖÜ][a-zäöüß'-]*)+)[^A-ZÄÖÜ]*";
string substitution = @"$1, ";
string input = @"Obama Mama told: Reporters in 19. Washington-Post in That he and Netanyahu-lll are opposed to Iran's calls for ""Death To America"".";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}