#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*substring.*$"
Local $sString = "slfkjslkfjle substring fkjkflkel" & @CRLF & _
"ffsubstringdkdkdkdd"
Local $sSubst = "$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)