const regex = /^.*substring.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*substring.*$', 'gm')
const str = `slfkjslkfjle substring fkjkflkel
ffsubstringdkdkdkdd`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);