import re
regex = re.compile(r"^.*substring.*$", flags=re.MULTILINE)
test_str = ("slfkjslkfjle substring fkjkflkel\n"
"ffsubstringdkdkdkdd")
subst = "$1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)