using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*substring.*$";
string substitution = @"$1\n";
string input = @"slfkjslkfjle substring fkjkflkel
ffsubstringdkdkdkdd";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}