$re = '/^.*substring.*$/m';
$str = 'slfkjslkfjle substring fkjkflkel
ffsubstringdkdkdkdd';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;