#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "( )(?=[^<]+>)"
Local $sString = "<please help me> hello everyone <HI!>"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)