re = /( )(?=[^<]+>)/
str = '<please help me> hello everyone <HI!>'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result