use strict;
my $str = '<please help me> hello everyone <HI!>';
my $regex = qr/( )(?=[^<]+>)/p;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";