$re = '/( )(?=[^<]+>)/';
$str = '<please help me> hello everyone <HI!>';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;