# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)( \1)+/\1/gm;t' <<< "the little cat cat is in the hat hat hat, we like it."