import re
regex = re.compile(r"(\w+)( \1)+", flags=re.MULTILINE)
test_str = "the little cat cat is in the hat hat hat, we like it."
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)