use strict;
my $str = 'the little cat cat is in the hat hat hat, we like it.';
my $regex = qr/(\w+)( \1)+/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";