const regex = new RegExp('(\\w+)( \\1)+', 'gm')
const str = `the little cat cat is in the hat hat hat, we like it.`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);