$re = '/(\w+)( \1)+/m';
$str = 'the little cat cat is in the hat hat hat, we like it.';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;